XPに繋がったプリンターをネットワーク経由でWindows7に追加したら…

nc2400にWindows7を入れてから2週間ほど。今のところXPと遜色ない感じで、一部を除いてはそれなりに快適に使うことができています。その一部とはプリンターです。

私の家で使っているプリンターはHP PSC 1210というプリンタです。が、このプリンター、サポート期間が去年で切れてしまっているのでWindows7に対応したドライバはHPからは提供されないとのこと。つまりはWindows7に同梱されているかWindows Updateでドライバをとってきてちょということなのです。

まぁ、このプリンタはUSB接続のプリンターなので、パソコンとプリンターを直接繋げばOS同梱のものかWindows Updateのものかを勝手に探してきてインストールしてくれます。が、私の家はネットワーク上のXPを介してプリンタに繋ぐようになってます。ので、いつものように『プリンタの追加』からネットワーク上のプリンターを探す形でインストールし、エラーも出ることなく正常にインストールできたとダイアログさんが告げてくれました。

…が、ここでテストプリントを実施するとなぜかWindowsのマークが印刷されない。このときは別段何とも思わなかったのですが、OpenOfficeのCalcで罫線が入った表を印刷したときに問題が。なんと罫線が印刷されないという問題に直面。PDFにしたらAcrbat Reader経由だから大丈夫か…と思ったら、罫線は印刷されるものの、『一』という文字以外は全く印刷されず。さらにはTwitterでつぶやいたところ、 Mage Whopper さんから『XPSで出力したら大丈夫かも』というお話をもらったので試したら、今度は罫線どころか文字すらもほとんど印刷されない状態。プリンタードライバにバグがあるのだろう…と、このときは半ばあきらめてしまったのでした。

続きを読む XPに繋がったプリンターをネットワーク経由でWindows7に追加したら…

Ubuntuパソコンの有線LAN認識不良と回避方法

最初に断っておきますが、回避方法といっても代価機器を購入しただけですので大層なことは書いてません :mrgreen:

以前にLavie G君でXubuntuで有線LANが使えないと次の記事で書いてたと思います。

結局のところXubuntuにしようがUbuntuにしようが、オンボードの有線LANは使えないということが判明。というのも、Terminalから

$ ifconfig

を実行したところ、本来なら有線LAN・無線LANにかかわらずシステムがNIC(ネットワークカード)を認識していればeth*(*は数字が入ります)として出てくるところが出てこないから。無線LAN用のPCカードを挿して同様にコマンドを実行すればeth*と出てくるし、実際PCカードを挿せばネットワークに繋がりましたし。

で、その原因はというと、このLavie君に使われているIntel Corporation 82557/8/9/0/1 Ethernet Pro 100がNICとして自動認識してくれないから。Terminalから

$ sudo lshw

$ sudo lspci | grep Eth

などをを実行すると、Ethernet controllerとしてこの名前が出てきてるのでハードウェアとしては認識していると思うんですけどねぇ。ちなみにこのNICをUbuntu(9.04)上で認識させる方法を検索してみましたが、今のところ見つけることは出来てません 😛

…まぁ、家で使う分には無線LANでなんにも問題はないのですが、夫の職場へ半ドナドナ状態の上に職場では有線LANしか使えないとのこと。なのに有線LANが使えないとあってはアップデートやらなんやらで結構問題があると考えたわけで…。

そんなこんなで有線LANポートのPCカードを近くの家電量販店で新たに購入することにしました。実際に購入したのはこちら。

IOデータ製の同様機能を持つ機種もあったのですが、使用している無線LAN用PCカードがBUFFALOで、同じBUFFALO製の方が問題も少なかろうと思ってこちらにしました。

で、実際に接続したときの認識結果は問題なし。Ubuntuを起動させて購入したPCカードを挿すだけでUbuntu君はLANポートを認識してくれました。Terminalから

$ ifconfig

を叩いたときも問題なくeth0の文字が出てきてましたし。…ただ、ケーブルを繋いで実際に動作するかまでは試していませんけどね(夫が帰ってくるのと一緒に一時帰宅をしてるのでケーブルを繋いで試す暇がないのです…)。

最良の方法はオンボードのNICをUbuntuに認識させるのが良いのですが、職場で使っているものを一時帰宅させている以上手間はかけていられませんし、システムをいじって不具合が起きると目も当てられない状態になってしまうので。というのもLavie君に付いてるCD/DVDドライブがそろそろ限界のようで、読み取りにガチャガチャ言った後エラーを起こしてくれることがザラでして…。

今はこれで解決! …ということにしておきます。ま、1つの結果に対していろんなアプローチがありますからね 🙂

XubuntuのファイルマネージャでWindows共有フォルダを開きたい!

最近Xubuntがご無沙汰になってしまってます。色々予定が入っていたのもありますが、大きいのはXubuntuからWindowsの共有フォルダを自動的に開けないこと。Google先生に聞いて探してみるとXubuntuからWindowsの共有フォルダを見る方法としてfusesmbを使う方法が紹介されているのですが、この方法だとWindowsの共有フォルダを手動でXubuntuのディレクトリにマウントしてやらないといけないようです。

…ですが、更に調べると最近のUbuntuやXubuntでは別の方法を使うことができるようです。それがgvfs-fuseを使う方法。読んでみるとその後の接続も簡単なようなのでこの方法でやってみることにしました。

まずパッケージとして次のものをインストールします。

  • gvfs
  • gigolo
  • thunar

でも私が入れたXubunt 9.04ではすでにいずれも入ってました。Thunarは『ファイルマネージャ』、Gigoloは『Remote Filesystem』として『Applications』から呼び出せます。gvfsを使って接続するのに必要なgvfs-fuseも調べるとすでに入っていることが確認できました。

で、gigoloからWindowsの共有フォルダへの接続は凡ミスのおかげで苦労はしたものの、凡ミスに気づいた後はすんなり接続できました(凡ミスの中身は共有フォルダ名の間違い…)。でもGigoloで表示されているアイコンから共有フォルダを開こうとしてもthunarが自動で開いてくれません。どうしたものかとGigoloのヘルプを見たり、Google先生に聞いてみたりしたものの結局解決策は見つけられず…。

更に調べてみるとgvfsを使うと~/.gvfsというディレクトリ内に自動で共有フォルダをマウントしているという情報をつかみ、Thunarからこのフォルダ内を確認してみると確かに共有フォルダがマウントされていました。ちなみに~/.gvfsはユーザーディレクトリの隠しディレクトリとなっているので、Thunarの設定で隠しディレクトリを表示するように変更する必要があります。

現状として確認できたことはこんな感じです。

  • gigoloによるWindowsの共有フォルダへの接続OK
  • gigoloからThunarが立ち上がらない
  • gvfsによって~/.gvfsディレクトリには自動でマウントされている

…さてさて。ユーザーディレクトリないの~/.gvfsディレクトリないに自動マウントされていることは確認できたものの、GigoloからThunarでその~/.gvfsディレクトリを開く設定方法がわかりません。色々調べてもGigoloから共有フォルダを選択すれば自動でThunar似て中身が見られるという内容ばかり。そんな訳で現状では手詰まり状態です。Gigoloの設定でファイルマネージャという項目には『gvfs-open』が設定されているのでそのままにしているのですが、ここを変えねばならぬのか…と『Thunar』と設定しても無駄でしたし…。

何か情報があればご教授願いたいものです……(T-T)