Google Maps for WordPress日本語版 Ver. 1.0.3-ja1.0.2でWarningが出る場合

先日、Google Maps for WardPress日本語版におけるコメント欄にてWarningが出るというご報告をいただきました。

早速調査したところ、1年ほど前に当ブログでGoogle Mapsにスタイルシートを適応できるよう追加したコードが中途半端に追加されてしまったようで、この改変で本来追加すべき関数がまるまる抜けていたがためにWarningが発生していました。

早速修正を施し、CSSを呼び出すのに必要なコードは追加しましたが、CSSにてGoogle Mapsのスタイルを指定しない人には不要だと思いましたので、wp-google-maps.php内にある次のコードをコメントアウトさせてVer. 1.0.3.-ja1.0.3として公開しました。

    add_action('wp_head', array($wpGoogleMaps, 'setLinkCSS'));

当プラグインでGoogle Mapsを公開する際にCSSにて書式を指定したいという方は上記のコードのコメントアウトを解除し、wp-google-maps.phpがあるフォルダにgoogleMap.cssという名前のファイルを作成してください。またgoogleMap.cssファイル内は次のように記述し、div.googleMapで指定されている中をお好みに記述してください。

@charset "utf-8";
 
div.googleMap {
…
}

なお今回の修正で追加した内容の詳細は『Google Map for WordPressをCSSファイルにリンクできるようにしました』という記事をご覧いただければと思います 😉

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です